• Members 5 posts
    Nov. 8, 2018, 9:38 a.m.

    Misago is a forum looks nice. And I want to build a forum base on misago.
    I want to add some element into frontend of misago. Such as a new captcha service.
    But I am new to web development. Even misago have a good coding style and its code is pretty easy to understant. But I don't know where to start editing.

    It seems that the source of frontend is bundled into one or two file using webpack(maybe browserify or something else). But I could'nt find any script about bundling. (I knows onlypackage.json, but no scripts there and npm tests failed.).
    I tried to use browserify to bundle index.js using browserify index.js misago.js but also failed. Maybe I just missed some setting, but figuring out what I missed is hard for me.

    So in a word, could you teach me how should i start if I want to edit the frontend part of misago?

  • Members 5 posts
    Nov. 8, 2018, 9:45 a.m.

    I also tried node .\gulpfile.js

    But error still exist:

    Microsoft Windows [Version 10.0.17134.345]
    (c) 2018 Microsoft Corporation. All rights reserved.
    
    C:\Projects\misago\frontend>node gulpfile.js
    C:\Windows\system32\cmd.exe - node  gulpfile.js[31704]: src\node_contextify.cc:628: Assertion `args[1]->IsString()' failed.
     1: 00007FF6446FDC55
     2: 00007FF6446D75C6
     3: 00007FF6446D7691
     4: 00007FF6446AAC9A
     5: 00007FF644ABDD22
     6: 00007FF644ABEF38
     7: 00007FF644ABE26D
     8: 00007FF644ABE18B
     9: 000003F9E33DC6C1
    

    Maybe is it a error of my system?

  • Members 5 posts
    Nov. 8, 2018, 10:11 a.m.

    I'm sorry that it's my fault that not able to run gulpfile.js. After I downgrade node to v8, it works.
    Just run gulp build, everything done.

  • Nov. 9, 2018, 5:51 a.m.

    Yup, this is documented in our readme:

    build does production build of Misago's assets, concating and minifying javascripts, css and images, as well as moving them to misago/static directory

  • Members 5 posts
    Nov. 9, 2018, 6:36 a.m.

    Thanks. I missed the readme.That was a stupid mistake.