• Members 1 post
    April 5, 2019, 4:25 a.m.

    when i login i got this erro from api

    AttributeError at /api/auth/
    'str' object has no attribute 'args'

  • Members 5 posts
    April 10, 2019, 3:32 a.m.

    It works just fine for me - can you elaborate?

  • April 11, 2019, 10 a.m.

    Can you please provide the error traceback? It should be in logs/error.log or in your console depending on how are you running your Misago site.

  • Members 1 post
    April 20, 2019, 3:05 p.m.

    Have same issue, just install Misago on my server, here's the log:

    [2019-04-20 22:02:16,428] ERROR Internal Server Error: /api/auth/
    Traceback (most recent call last):
      File "/usr/local/lib/python3.6/site-packages/django/core/handlers/exception.py", line 41, in inner
        response = get_response(request)
      File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py", line 178, in _get_response
        response = middleware_method(request, callback, callback_args, callback_kwargs)
      File "/usr/local/lib/python3.6/site-packages/django/middleware/csrf.py", line 294, in process_view
        return self._reject(request, REASON_NO_CSRF_COOKIE)
      File "/usr/local/lib/python3.6/site-packages/django/middleware/csrf.py", line 163, in _reject
        return _get_failure_view()(request, reason=reason)
      File "/usr/local/lib/python3.6/site-packages/misago/admin/views/errorpages.py", line 56, in decorator
        return f(request, *args, **kwargs)
      File "/usr/local/lib/python3.6/site-packages/misago/core/errorpages.py", line 112, in csrf_failure
        return _ajax_error(403, _("Request authentication is invalid."))
      File "/usr/local/lib/python3.6/site-packages/misago/core/errorpages.py", line 15, in _ajax_error
        'detail': get_exception_message(exception, default_message),
      File "/usr/local/lib/python3.6/site-packages/misago/core/utils.py", line 147, in get_exception_message
        return exception.args[0]
    AttributeError: 'str' object has no attribute 'args'
    
    
  • April 20, 2019, 3:10 p.m.

    This error is caused by CSRF failing, which is most likely caused by not having the HTTPS. This is already discussed in more detail here.

    Thanks anyway! I will fix this crash in next Misago release.