• Members 4 posts
    Nov. 11, 2019, 7:04 a.m.

    Hello~

    I have tried to install the Misago (the main repo) and the misago_docker on my Raspberry Pi 4B.

    Misago in the main repo works well on my Raspberry Pi, and I can visit it directly by typing http://127.0.0.1:8000 in browser. But it only works in the DEBUG mode. A further sought is to deploy the production version: misago_docker. Currently, to install the misago_docker on Raspberry Pi, one needs to modify the default configuration and please check this thread for details.

    The issue of this thread focuses on how to visit the misago via browser in local networks. As required, one needs to give a hostname to the appctl at the setup step. I thought 127.0.0.1 should be the answer but it's not, or it is only part of it. I have also tried to change the port of nigx from 80 to 8000 using docker-compose.override.yaml file, but nothing changed. It seems that I need to modify more configurations or more containers in the docker. Could anyone give some tips about that?

    Any help is appreciated!

  • Nov. 15, 2019, 1:04 a.m.

    Hey, sorry for being so late with response!

    Could you explain first what are you trying to accomplish? Is this a forum for you and your friends to interact with? How do you plan for users to access this forum? 127.0.0.1 will work from Raspberry, but not for traffic coming from outside it. They will need to know your server's IP address to connect with it.

    I would propably go about creating docker-compose.override.yml that would disable nginx-proxy and nginx-lets-encrypt services:

    services:
      nginx-proxy:
        restart: "no"
        command: ["echo", "Service disabled"]
        entrypoint: ["echo", "Service disabled"]
    
      nginx-lets-encrypt:
        restart: "no"
        command: ["echo", "Service disabled"]
        entrypoint: ["echo", "Service disabled"]
    

    I would also include custom NGINX service (or make on run on host) and give appctl whatever url for host, eg. localhost - you should be able to change this to http://127.0.0.1 in admin panel after setup.

    You will also need to override settings.py to allow all hosts to connect to the site:

    # create settings_overrides.py right next to settings.py
    ALLOWED_HOSTS = ["*"]