• Contributor March 13, 2013, 4:18 p.m.

    Hi,

    I know there are people willing to test (currently) the most completed version of Misago - 0.5.x, and have a little fun with it. Who knows, maybe someone will manage to find and report some bug?
    Unfortunately Misago is not php-based, so running it on localhost is not as easy as the other forums. Many people just give up at the beginning: installing python and dependencies, without any experience can be hard...

    To make it easy I prepared a package, that reduces the process of downloading, configuring and updating Misago to 4 minutes :)

    Fast installation and Misago launching

    1. Download and extract the package: instant-misago.7z. Keep in mind, that after unpacking it will occupy about 100MB on your hard drive.
    2. Modify file: Misago-Config.ini filling it with administrator data - otherwise you'll not be able to login into forum.
    3. Run script Misago-start.bat. The latest version of Misago will be downloaded, configured and launched. To stop the server, just close the console window.

    Ok, Misago server is running. Now, how to reach it?

    URL to your forum:
    localhost:8000/

    URL to the admin panel:
    localhost:8000/admincp/

    How to update Misago to the latest version from the repository?

    1. Launch script Misago-update.bat. Forum will be updated to the latest version.
    2. If Misago does not work properly after update, try the script Misago-FullUpdate.bat. Note, that entire forum will be rebuild from scratch, so you'll lost all your data! In fact, this step shouldn't be needed anymore, as Misago supports migrations.

    I moved Misago directory and it stopped working. How to fix it?

    Just run the script Misago-ConfigOnly.bat, or perform update (see above).

    Launching Misago from removable media

    As far as you launch the configuration script each time you change the computer, you shouldn't encounter any problems.

    I have found a bug! Where and how to report it?

    Firstly, perform a full update (to confirm that the error occurs on a clean board too) using a script Misago-FullUpdate.bat.
    If the problem still persists, go to issues list on github and make sure the issue isn't already reported. If not, go ahead and make use of the New issue button. However, report an error, you must have a Github account - if you do not have one, create it! It's a cool site with many interesting projects.
    If you really do not want to create Github account, you can eventually just make new thread in a proper category on this site.
    Be sure to describe precisely, step by step, how to trigger that issue. If you cannot, just describe the circumstances in which problem occurred.
    Also keep in mind that Misago is still under heavy development and some features simply does not exist yet. Assume, that if some functionality tries to run, but couldn't do this correctly or show an exception, it's a 90% chance, this is a bug to report. But, for example, if you click on button and nothing happens, probably it's just not implemented yet.

    How it works? A few technical details...

    Instant-misago package contains slightly trimmed version of instant-django by Kevin Veroneau, with my script to download, configure and run Misago. It also has all required dependencies.
    Latest version is downloaded from git repository: github.com/rafalp/Misago, and unpacked into "Misago" directory.
    The script creates one main administrator (with data from Misago-Config.ini) and configures SQLite database, located at Misago/database.db. You cat view and modify it with a very good extension for Firefox: Sqlite manager
    The configuration is created in fx_deployment/ directory, and script that runs everything is created as fx_manage.py (based on the original deployment/andmanage.py*), so your configuration shouldn't conflict with later updates.

    Misago as a public forum on dedicated server?

    Sorry, it's too early. Misago is still in heavy development.

    And... what about Linux?

    Unfortunately, instant-django (and so, my package) is compatible with Windows only. However, thanks to the packet system, instalation of Django with all dependencies shouldn't be that hard... For example, Ubuntu has it's own packages:
    wiki.ubuntu.com/Django

  • Contributor April 1, 2013, 2:41 p.m.

    Package updated to support current version of Misago (0.2) :)

  • Contributor Aug. 11, 2013, 5:57 p.m.

    Unfortunately it's no longer working, due to default configuration changes and python 2.7 required.

    I'll try to update it later.

  • Nov. 6, 2013, 2:11 a.m.

    What's the latest on this, and has anybody tried to make a similar package for installation on a Linux distribution?

    Considering that Linux is the deployment OS of choice, I think it will be of most use to people.

  • Jan. 31, 2014, 6:46 p.m.

    I'd love to see work on this returned, as I'm absolute incompetent at installing django/similar.

  • Contributor Jan. 31, 2014, 6:49 p.m.

    I'll try to revive this next week. Currently I'm a little too busy.

  • Contributor Feb. 2, 2014, 6:22 p.m.

    I've uploaded new package that supports newest version: 0.5.1 and is more compact :)

    Instructions remain the same.

  • Project Lead Feb. 2, 2014, 6:53 p.m.

    Just a friendly reminder:

    This utility is here for you to let you get up Misago running quickly and painlessly on localhost to play around. DON'T USE IT FOR REAL INSTALATIONS.

  • Feb. 3, 2014, 5:58 p.m.

    Hmm, thanks for reviving this, but I have got an issue where it's saying python27.dll can't be found - the sub-folder Python27 does exist within my Instant-Misago installation.

    And Python27 itself is installed on my PC.

  • Contributor Feb. 3, 2014, 6:02 p.m.

    I'll check this in a moment. That's what you'll get testing only on localhost, sigh...

  • Contributor Feb. 3, 2014, 6:10 p.m.

    Can you try re-downloading and running it again? I added missing libs.

  • Feb. 3, 2014, 6:13 p.m.

    Works! Thanks a lot for this, it's so useful.

  • March 4, 2014, 6:02 a.m.

    http://localhost:8000/ doesnt work for me

  • Contributor March 4, 2014, 7:51 p.m.

    What do you see in the console after you turn it on?

  • March 4, 2014, 7:55 p.m.

    Nevermind got it work.

  • Aug. 29, 2014, 7:13 p.m.

    It's not working if you have special characters in the name of windows user folder. For example "Michał"

    ev4yn6.jpg

    JPG, 295.1 KB, uploaded by IreuN on Aug. 29, 2014.

  • Aug. 28, 2016, 10:23 a.m.

    how can i fix this
    problem

  • Contributor Aug. 28, 2016, 3:04 p.m.

    Hi. I've updated this package to the newest version. Could you please re-download it and try again?

  • Aug. 28, 2016, 3:34 p.m.

    thanks worked for me

  • panorama_fish_eye

    Thread has been unpinned.