• Members 4 posts
    Nov. 8, 2019, 7:29 p.m.


    I have installed Misago on my raspberry pi 4 following Misago (also tried misago_docker but found the postgresql-10 is currently not available for RPI ). I have searched this forum and found a thread on the same issue created 2 years ago. This thread doesn't help because "category.depth" has been replaced by "category.level" in the current code.
    I know there should be a list of err logs, but I even don't konw how to find them out. Could anyone tell me how to get the error logs? what I got just like:
    misago_1 | [08/Nov/2019 17:50:33] "GET / HTTP/1.1" 500 3063
    misago_1 | [08/Nov/2019 17:50:37] "GET /favicon.ico HTTP/1.1" 500 3063
    misago_1 | [08/Nov/2019 17:51:10] "GET / HTTP/1.1" 500 3063
    misago_1 | [08/Nov/2019 17:51:12] "GET /favicon.ico HTTP/1.1" 500 3063


  • Nov. 9, 2019, 8:37 p.m.

    Hey there!

    Docker setup on main repo is 100% set for development and can't be used in production deployments.

    If PostgreSQL 10 is too large, I would try creating docker-compose.override.yml with PostgreSQL 9 in your misago-docker deployment.

  • Members 4 posts
    Nov. 10, 2019, 6:47 p.m.

    Thanks for your reply. I have tried to create an override file to change the default settings, but I still get the same error message as previous by doing this.

    I think I have misunderstood the error as it says "cannot locate postgresql-client-10". After searching the cache, it turns out there only exist "postgresql-client" and "postgresssql-client-11". So I modify the Dockefile at the misago folder from "postgresql-client-10" to "postgresql-client" instead of a docker-compose.override.yaml file, and I sucessfully go through the deployments.

    But, how could I get into the forum as the way in the main repo, for example, http://localhost:8000? Since I don't have a hostname, I give the hostname as and set the nginx-docker port to 8000 (using the docker-compose.override.yaml file) , but it doesn't work. Although it is not an issue for misago itself, it will be helpful for those who are new to web services and want a forum in his raspberry pi. Could you please give some tips?

  • Nov. 10, 2019, 6:50 p.m.

    I feel that running public forum on Raspberry PI is separate issue to one asked in OP. Could you create separate thread for it?

  • Members 4 posts
    Nov. 11, 2019, 7:36 a.m.

    fine, thread created

  • Nov. 15, 2019, 12:55 a.m.


    I'll follow up with using raspberry PI in new thread, but would also like to add extra context here why you CAN'T use main repo to setup production site.

    The reason for this is primarily because it uses Django's dev server to serve the site over the, and this setup has serious limitations that make it impossible to use for "serious" deployments.

    First, Django's server doesn't serve static files (CSS, JavaScript or Images) or user uploaded files when DEBUG is disabled. If you were to disable DEBUG on your site, you will need to introduce NGINX or some other HTTP server to the setup for this to work... but this is smaller of the issues involved here.

    The big issue is that Django's dev server was designed with intention that no more than single user (the developer) will be interacting with it at any time. Sure, multiple users will be able to connect to it just fine from their browsers, but Django uses global state to store certain data about users. In proper deployment this global state lives for the duration of HTTP request, and each HTTP request gets its own global state separated from other states. In dev server there is only a single instance of this global state. This means that weird and unpredictable bugs and security problems will surface that don't happen otherwise as Django stores and reads different things in this state happy to assume they belong to current user (and didn't leak from previous one). Over time Misago got better about not using this global state, but there's still Django beneath that does.